Apache Log4j < 2.8.2 SocketServer反序列化漏洞 - 漏洞预警

  1. 门户首页
  2. 漏洞预警

Apache Log4j < 2.8.2 SocketServer反序列化漏洞

普创网络应急响应中心监测到Apache Log4j官方披露1.2系列版本的Log4j存在反序列化漏洞(CVE-2019-17571)

漏洞描述
Log4j 1.2系列版本引入了一个SocketServer类,该类在处理反序列化操作时可导致任意代码执行。Log4j是最常用的apache日志开源项目,使用非常广泛。在使用Log4j的SocketServer类创建TCP或UDP Socket监听服务处理接受数据,且数据可被攻击者篡改时可实现漏洞利用。利用场景苛刻,风险较低。

漏洞评级
CVE-2019-17571 低危

影响版本
Log4j 1.2系列版本

安全版本
Log4j >= 2.8.2

安全建议
1. 升级Log4j至安全版本:https://logging.apache.org/log4j/2.x/
2. 排查并禁止是否使用Log4j的SocketServer类创建TCP或UDP Socket服务,未使用Log4j的SocketServer类功能不受漏洞影响。